Detailer's Magic

Fractal Design Detailer is the amazing 3D paint program. With Detailer, you can paint directly on 3D models,
adding color, texture, shine, and reflection effects. It’s the closest thing to actually holding an object in your
hand and painting on it.

Detailer is easy to use. It allows you to create intricate, realistic surface maps while bypassing much of the
technical gauntlet that makes most 3D programs seem difficult.



Detailer for 2D and 3D

Detailer is an incredible bridge between 2D and 3D. It complements both 2D paint programs and 3D
modeling programs.

If you’re a 2D artist, Detailer helps you create depth shading and oblique views of your subject. After creating
a Detailer rendering, you can create a 2D collage right in Detailer. You may also take renderings into Fractal
Design Painter or any other 2D art program and composite them with other images. Detailer renderings
include an 8-bit mask, so compositing is smooth and easy.

If you’re a 3D artist, Detailer is a one-stop shop for creating texture, bump and other surface maps on your
3D models. Detailer provides a direct-manipulation environment for detailing 3D surfaces. There’s no more
bouncing your surface maps back and forth between your image-editing and 3D rendering applications.



Importing/Exporting Models

Detailer can import a model created in another 3D program. After you’ve detailed the surface of the model,
you can export it. If the correct format is used, all of the surface maps and settings are saved with the
exported model. When you add the model to your 3D scene, all of the work you did in Detailer will be intact.

Detailer includes a set of 3D primitive objects and has the ability to import models in several 3D formats. You
can assign texture, bump, reflection, highlight, and glow maps to any object in the model. These maps may
be at any resolution and come from a range of sources—imported paintings and photographs, Detailer’s own
Patterns and Textures, or images painted from scratch within Detailer.

Detailer can import and export 3D models in Detailer-native, QuickDraw 3D2 (3DMF), 3D Studio? (Windows
version only) and DXF formats. Included extensions for Ray Dream Designer2 and Ray Dream Studio? import
and export models in Detailer format, so you can use Detailer with models you create in these programs.



Developing Maps

When you’re developing your maps, you can paint directly on the object or work in the 2D view of the map
image. Paint where it’s convenient for you. Detailer automatically updates the brush stroke to the other
window. This means that if you paint on the model object, the stroke will also appear in the associated map
image window, and vice versa.

Detailer provides an arsenal of painting tools. Paint directly on the model using the wonderful Natural-Media
brushes Fractal Design Painter is famous for. And if that’s not enough, you can customize and create your
own specialty brushes.

Detailer supports multiple floating selections or “floaters,” so imported Painter or Photoshop? files maintain
independent floaters and layers. You can export your models with their maps and incorporate them in your
3D scenes and animations. You may also render your model right in Detailer, then use the mask to aid in
compositing with other images.

Detailer’s Multiple Undo feature allows you to step back through your actions up to 32 times!

Detailer can also open and save map image files in a variety of formats, including RIFF, PICT, TIFF, BMP,
JPEG, Photoshop 2.x, and Photoshop 3 (complete with layers).



Mapping on Models

A Detailer model may be comprised of a number of objects, and each object may have its own set of maps.
As many as five maps can be active and displayed on each object. Each map type controls one characteristic
of the object’s appearance:

* Texture Maps give the model its color.
* Bump Maps give relief to the surfaces.
* Highlight Mask control which areas are shiny or matte.

e Reflection Mask indicate which areas reflect their surroundings. Environment maps that you import define
the reflection image.

* Glow Maps add diffuse color after texture and lighting have been applied.

Detailer supports multiple mapping methods: cylindrical, spherical, cubical, pass-thru, and UV (implicit). Each
map can have its own mapping method, which you can change at any time.

Detailer provides flexible mapping controls, including the ability to resize and resample maps, adjust
mapping scale, and move the map seam and origin.



Detailer's Lighting Controls

Detailer provides control over the lighting environment. You can illuminate models with up to ten colored
lights and set their brightness and concentration. With the Light tool, you can click on the model to create a
light shining there.



High-resolution Rendering

Detailer can render 3D models at any resolution, complete with anti-aliasing and mask information.
Composite renderings directly in Detailer, or use a paint or image-editing program like Fractal Design Painter.



About this User Guide

This Detailer User Guide assumes you’re familiar with your computer’s operating system and basics like
clicking and dragging.

See also:
Organization
Section | Introduction
Section Il Models, Maps and Light
Section Il Imagery

Section IV Advanced Techniques
Reference

Conventions



Organization
This Help System is organized into five sections, comprised of several chapters each.

The sections divide 3D information from 2D information and separate primary features from those that are
more advanced.



Section | Introduction

This section describes the Detailer interface and gives the basics of working in Detailer. Full tutorials are
included in the Fractal Design Detailer User Guide.

See also:

Getting Acquainted with Detailer
Detailer Basics



Section Il Models, Maps and Light

This section covers Detailer’s 3D features. The first chapter of this section covers model features—acquiring,
manipulating, saving and exporting. The second chapter covers surface maps, including the methods and
features for applying and controlling them. The third chapter of this section covers the features for applying
light to the model.

See also:
Working with Models

Using Maps
Using Lights



Section Ill Imagery

This section covers the basics of developing images for use as maps. Starting with the features of image
windows, the chapters proceed through image materials, painting, and advanced painting.

See also:
Working with Images
Image Materials
Painting
Customizing Detailers Brushes




Section IV Advanced Techniques

This section covers some of the more powerful features and techniques for creating and manipulating
imagery:

® Selections and masks increase your control for developing imagery.
* Floating selections or “Floaters” let you move and manipulate imagery within a document.
* The Image Hose lets you paint with images.
® Special effects offer practical and creative ways to create and modify imagery.
* The Printing chapter describes how to set up and use Detailer’s print features.
See also:

Selections and Masks

Floaters

Using the Image Hose

Applying Effects

Printing



Reference

The Fractal Design Detailer User Guide includes a Reference section. This section includes the appendices,
glossary, index and software licensing agreement. Appendix A, “Designing Maps,” provides technical
information on designing surface maps. Appendix B, “Using Detailer with Other Programs,” provides
information about using Detailer with other programs, including features for exporting and importing Detailer

models in Ray Dream Designer or Studio. Appendix C, “Optimizing Memory Usage,” describes memory
considerations and offers tips on getting the most out of Detailer.



Conventions

Detailer is available for Macintosh and Windows. Program functionality is identical on the two platforms. Only
keyboard commands and the appearance of document windows, palettes and dialogs differ.

This user guide describes Detailer for both platforms. The keyboard commands for both platforms are given.
For example: “To save the file, press Command-S (Macintosh) or Ctrl+S (Windows).”

Screen captures of the palettes and dialogs are divided between the two platforms. Some sections use
Windows captures,
others use Macintosh.

Many Detailer features are available on menus. Some menu items offer sub-menus. This user guide
describes selecting these features as follows: In a distinctive font, the menu is identified, followed by an
arrow and the feature name. For example: File menu> Save.

If the feature is on a sub-menu (pull-right menu), an additional arrow and item appear. For example: Edit
menu> Paste> Into New Image.

Some palettes contain menus. In this case, the palette is identified, then the standard menu notation is used.
For example:

Materials palette: Object menu>

Set Object Color.

The Controls palette is a special palette whose content changes based on which tool is selected. This palette
is referred to as the Controls palette: Tool Name —for example, Controls palette: Floater Adjuster tool.



Getting Help

Detailer offers help information from within the application. This help is an abbreviated version of text from
this manual. Refer to your Quick Start guide for more information on getting help.

The Detailer Quick Start Guide contains information about how to install Detailer, set application memory,
access the Help system and use the Detailer CD.




Technical Support

You will find the answers to most of your questions within the pages of this User Guide. If you need further
assistance, you may contact Fractal Design’s Technical Support in any of the following ways:

www: http://www.fractal.com/
See the technical support
on-line guide for answers
to frequently asked
questions.

Phone: 408 430-4200 between
the hours of 8am and
5pm,

Pacific Standard Time.

FAX: 408 438-9672
Please fax a copy of the
Troubleshooting worksheet
found in the back of this
User Guide.

Internet: mac_support@fractal.com
win_support@fractal.com

Fill out and e-mail the form
at
http://www.fractal.com/sup
port/tech/contact.html

Mail: Technical Support
c/o Fractal Design
Corporation
P.O. Box 66959
Scotts Valley, CA 95067

For More Information

For more
information
about Fractal
Design
products, see
our World
Wide Web site
on the
Internet:

WWW: http://
www.fractal.com/

To exchange
tips and
techniques
with other
users, see the
following
online forums:



AOL: Keyword “Fractal”

CompuServe: “GO GUGPRA»

Getting Acquainted with Detailer
See also:
An Overview of Detailer
The Tools Palette
Palettes and Drawers
Libraries and Movers
About Plug-Ins
Setting up Ray Dream Designer to Export Detailer Models
Setting Detailer’s Preferences
Setting Pressure Sensitivity
Customizing the Interface
Setting Multiple Undo Levels

Preferences for Windows




An Overview of Detailer

In Detailer, you’ll create surfaces on
models by wrapping them with images.

The model you’re working on appears in the Model Window. Images appear in image windows. Detailer
supports these two document types.

Some of Detailer’s features are for working in 3D on the model. Some features are for creating and working
with images; and some features are for applying those images to the model, a process called mapping.

Detailer has a wealth of features. They’re organized (according to function) in pull-down menus and palettes.
Palettes are windows containing tools, options, and materials that float over your document windows.
Detailer has four main palettes—Tools, Controls, Brushes and Materials.

You can control the display of these
palettes using the Window menu.



The Tools Palette

In the Tools palette, you will find tools for viewing and navigation, adding light, painting, filling with color, and
creating selections. If the Tools palette is not displayed on your screen, you can display it by choosing
Window menu> Tools.

The Controls palette contains options for the current selected tool. The Controls palette updates as you
select different tools to reveal the selected tool’s options. If the Controls palette is not displayed on your
screen, you can display it by choosing Window menu> Controls.

See also:
The Object Selection Tool
The Virtual Trackball Tool

Magnifier Tool
Grabber Tool

The Dropper Tool
The Brush Tool

The Paint Bucket Tool
The Text Tool

The Light Tool
The Selection Tools

The Lasso Tool

The Floater Adjuster Tool



2D and 3D Tools
Some tools are exclusively for working in the Model Window. Some tools are only for working in 2D image
windows. Several tools may be used in both windows.

The Tools palette will change, depending on whether the Model Window or an image window is activated.
Detailer dims the icons of tools that are not available for the current window.



The Object Selection Tool

The Object Selection tool lets you identify which object (in a model comprised of several) you want to detail.
The Controls palette shows technical information on the selected object.

The Object Selection tool works only in the Model Window.



The Virtual Trackball Tool

The Virtual Trackball tool lets you rotate your view of the model in the Model
Window. The Controls palette offers sliders for controlled rotation on each of the three axes.

The Virtual Trackball tool rotates the view of the model in the Model Window; it does not rotate the model.
Lights remain fixed in relation to the surfaces of the model. When you use the Virtual Trackball tool to rotate,
you view the model from different angles. For more information about using the Virtual Trackball tool, see
“Working in the Model Window”

In an image window, the Virtual Trackball tool functions as the Rotate Page tool from Fractal Design Painter.
Rotate Page lets you rotate the image canvas to an angle that’s comfortable to your drawing style.

Using the Virtual Trackball tool, drag (in the image window) to rotate your page. When you want to set the
image back to its natural orientation, click in the window.

The keyboard shortcuts for this tool work regardless of the window type. Use Option-Spacebar for Macintosh
or Spacebar+Alt for Windows.



Magnifier Tool

The Magnifier tool allows you to magnify areas of an image when you are performing detailed work or zoom-
out to get an overall view of an image. Click once to zoom in. To zoom out, hold down the Option key for
Macintosh, Alt for Windows and click.

Click and drag to zoom in on a given rectangular area of an image. You can also use the Controls palette to
set the zoom level in image windows.

The Magnifier works in both the Model Window and image windows.

You can access the Magnifier tool while any other tool is selected. For Macintosh, hold down Command-
Spacebar and click to zoom in or Command-Option-Spacebar and click to zoom out. For Windows, use
Spacebar+Ctrl to zoom in and

Spacebar+Ctrl+Alt to zoom out.



Grabber Tool

The Grabber tool gives you a quick way to scroll the image or the model. You may also set the zoom level on
the Controls palette for an image window when the Grabber tool is selected.

The Grabber works in both the Model Window and image windows.

You can access the Grabber tool from any tool by holding down the Spacebar.



The Dropper Tool

The Dropper tool lets you pick up a color for use elsewhere. The Controls palette shows you values for the
color. When you select a color with the Dropper tool, that color becomes the current color on the Materials:
Color palette.

The Dropper works in both the Model Window and image windows.

You can access the Dropper tool from any color related tool by holding down Command for Macintosh, and
Ctrl for Windows. These tools include the Brush, Paint Bucket, Rectangular and Oval Selection tools and the
Floater Adjuster.

When used on a model, the Dropper picks up the color of an object without calculating the color of a light on
the surface.



The Brush Tool

The Brush tool lets you paint strokes directly on the model, on images or on a floater. You can set Opacity,
Grain, and Draw Style (Freehand or Straight Lines) in the Controls palette.

The Brush tool represents a category of marking tools. Within the Brush category are pencils, crayons, pens,
chalk, airbrushes, the remarkable Image Hose, and more. The Brushes palette lets you choose between
these tools and gives you access to controls that let you customize the brushes.

See also:
Painting
Advanced Painting

The Brush tool works in both the Model Window and image windows.

You can use the Brush tool to paint on a floater.
A floater is an image element or layer that hovers over the canvas or background.




The Paint Bucket Tool

The Paint Bucket tool lets you fill an area. The Controls palette shows choices for what area to fill and what to
fill it with.

The Paint Bucket works in both the Model Window and image windows.



The Text Tool

The Text tool lets you create text floaters. Use the Controls palette to choose a font, point size, and set
tracking.

The Text tool works in both the Model Window and image windows.



The Light Tool

The Light tool lets you click on the model to create a light that shines there. The Controls palette gives you
sliders to adjust the light you create.

The Light tool works only in the Model Window.



The Selection Tools

The Selection tools select an oval or rectangular area. When you create a selection, its coordinates are
displayed on the Controls palette.

These tools share a space on the Tools palette. Only one will appear at a time. To select the other tool, hold
down on the icon and when the icon for the other tool “pops-up” select it. You may also switch between the
tools on the Controls palette.

The Selection tools work only in image windows.
Rectangular Selection Tool
The Rectangular Selection tool allows you to create square or rectangular selections.
Oval Selection Tool

The Oval Selection tool allows you to create circular or oval selections.



The Lasso Tool

The Lasso tool lets you create a freehand selection area. The selection automatically snaps closed when you
let up on your mouse or stylus. On the Controls palette, you can choose to add or subtract from an existing
selection.

The Lasso tool works only in image windows.



The Floater Adjuster Tool

The Floater Adjuster tool allows you to select and adjust floaters. Click once to select one floater, or shift-
click to select additional floaters.

Floaters are image elements that float above the background image. The Controls palette lets you change
opacity, feathering, composite methods and floater layer order. It also allows you to group and drop
floaters.

The Floater Adjuster works in both the Model Window and image windows; however, not all functions are
available in the Model Window. The following functions of the Floater Adjuster are restricted to image
windows:

® Selecting floaters by dragging a marquee.

* Adjusting a reference floater by dragging its handles.



Palettes and Drawers

See also:
Using Palettes
Rearranging Palettes
Viewing and Hiding Palettes
Viewing Additional Palette Controls
Using ltems in Palettes
Using Palette Drawers
Locking Items on the Drawer Front
Tearing Off Palettes
Cleaning-up Palettes



Using Palettes

Detailer’s controls are organized into palettes. The Tools and Controls palettes are main palettes with every

function visible (no drawer mechanism). The Brushes palette is a main palette with pull down menu options

and a drawer containing brushes. The Materials palette is a main palette that holds several subpalettes. The
main palette pull down menus with additional options for each subpalette.

* The Tools palette determines your current activity. For example, you use this palette to tell Detailer
whether you want to draw, zoom in on a document, or select part of an image.

* The Controls palette changes to reflect options for the selected tool in the Tools palette, and to give you
instant access to the tool’s main functions. For example, when you have selected the Brush tool, the Controls
palette shows your Draw Style options.

® The Brushes palette is where you choose from Detailer’s wealth of drawing, painting and image editing
brushes. Brushes can be moved from inside the palette drawer to the drawer front.

The Materials palette is where you select your materials—from the basics, like a color for your pencil, to
unusual patterns, textures, lighting for the model, and the five map types you’ll apply to the model. The
subpalettes of the Materials palette are Color, Texture, Object, Pattern and Light.

See also:

Palette Tips



Palette Tips:
* Arrange your palettes so you can find and identify controls more effectively. Make sure that open palettes
don’t overlap each other. Palettes hidden in this way can be hard to find.

® Lock your favorite brushes to the Brushes Palette drawer front for quick access.

* If you have two monitors, use one to display the palettes, and use the other monitor to work in the
document window.




Rearranging Palettes
You can drag a palette to any location that’s convenient for your work. You can also stack palettes together
to save space. When palettes are moved in close proximity, they will snap together.

Detailer saves your palette arrangement, including locked items, so that it appears as you left it, the next
time you start the program.



Viewing and Hiding Palettes

You can hide a single palette by clicking its close box. You can display a palette by choosing its name from
the Window menu or using the key combination shown on the Window menu.

To hide all of the palettes, choose Window menu> Hide Palettes or press Command-H (Macintosh) or Ctrl+H
(Windows). Choose Window menu> Show Palettes again to display the palettes.



Viewing Additional Palette Controls

Many of Detailer’s palettes have additional controls that can be displayed or hidden, depending on the task
at hand. If you have opened a subpalette, you can expand it by clicking its grow box. For example, the

Materials: Color palette can be expanded to show the Color Variability sliders. Click the grow box again to
hide them.



Using Items in Palettes

To select an item from the front of a palette:
® Click the item’s icon.

A red outline appears around the icon you have selected. If you have clicked on an icon representing a
subpalette, the palette displays the options for that subpalette.

For example, when you click the Texture icon on the Materials palette, the palette appears along with a
drawer containing a collection of different textures. You can collapse this subpalette by clicking its icon again.

To select a menu item from the front of a palette:
® Choose it from a menu above an icon.

Some menu items open other palettes. For example, you can open the Floater List palette by choosing
Floater List from the Materials palette: Object menu.

When you’ve finished using the Floater List, you can close the palette by clicking its close box.



Using Palette Drawers

You can open the drawer of a main palette or subpalette to see the other items inside the drawer. The
pushbar indicates which palettes or subpalettes have drawers.

Storing items in closed drawers gives you more screen space. You will keep items on the drawer front that
you use most often and retrieve other items when you need them. For example, you would keep the most
often used textures on the front of the Texture subpalette. You would open the texture drawer to retrieve a
texture you use less often.

To retrieve items from inside a drawer, open the drawer by clicking the pushbar. A down arrow on the
pushbar means the drawer can be opened. You can click anywhere on the pushbar to open and close
a drawer. There are three methods for retrieving items from drawers:

* by clicking the icon
® dragging the icon
® by selecting the item’s name from the pop-up menu.
In some drawers, you’ll see a Library button. You can click it to reload the drawer with a new set of materials.
See also:
Libraries and Movers

You can access any palette drawer while in the effects dialogs. Your new selection updates in the preview
window. For more information about effects, see Applying Effects.

To take items out of a drawer by clicking:
Open the drawer and click the icon for the item you want.

The item will move to the front of the drawer, and it will be outlined in red to show that it is selected. Detailer
automatically replaces the least recently used item.

Iltems that are already on the front of the drawer are ghosted inside the drawer. When you put an item away,
it goes back to the same location so that you can always find it easily.

To take items out of a drawer by dragging:
Once the drawer is open, you can drag items out of the drawer to a specific position on the drawer front.

If you want to rearrange an icon’s position on the drawer front, first it will have to be replaced by an icon
from the drawer. Then you can drag the icon from inside the drawer onto the desired position on the drawer
front.

To use the pop-up menu to take items out of a drawer:
1 1o select an item by name, click the pop-up menu to display a list of all the items in the drawer.

2 Highlight the item you want and let up on your mouse or stylus to confirm your selection. The item’s name
appears on the pop-up and its icon appears on the drawer front outlined in red.

3 Click the pushbar to close the drawer.



Locking Items on the Drawer Front

You can arrange the items you use most frequently on the drawer front and lock them in place. When an item
is locked, Detailer will not put another item in its place. You will want to lock your favorite tools to the front of
the drawer so they are always there when you need them.

To lock items in place:
1 Drag each item out of the drawer to where you want it on the drawer front.

2 For each item you want to lock, click its icon and hold it down until a tiny green light goes on under the
icon. When you let go, the light stays on to show that the item is locked.

The item stays locked until you unlock it by pressing down on the icon again until the green light goes off.
Detailer lets you lock all but one item on any drawer front. One item must remain unlocked to allow a space
for any new item you might select.



Tearing Off Palettes

There are times when you’ll want to work with two palettes that usually aren’t available at the same time.
For example, you might want to work simultaneously with the Texture and Color subpalettes.

If you want to work with two subpalettes side-by-side, you can “tear off” one of them to display it separately.
Just drag its icon off the main palette. The torn off palette appears where you drop it.

When you no longer need the palette you’ve torn off, just click its close box.

Remember that one subpalette must remain displayed in the main palette. The selected palette will remain,
so you must drag one of the other palettes. If you want to tear off the current, selected palette, select a
different palette first.



Cleaning-up Palettes

You can choose Window menu]> [Clean Up palettes] to stack palettes in their collapsed state along the edge
of the screen.



Libraries and Movers
See also:
What are Libraries?

Adding tools or materials to the Current Library
Loading Alternate Libraries

Customizing Libraries

Creating a New Library

Accessing the Movers

Moving Items between Libraries
Modifying a Library

Default Libraries



What are Libraries?

A library is a saved collection of similar tools that can be loaded into a palette. For example, Detailer’s built-
in brushes (and their variants) are contained in the default brush library (Detailer Brushes), which is loaded
when you launch Detailer. As you customize brushes and other materials, you can save them into you own
libraries.

Libraries are available for textures, patterns, gradations, brushes, nozzles, floaters and lighting. You may
have any number of libraries, but only one (of each type) will be open at a time. When you want other tools,
you can load the alternate libraries.

Libraries allow you to extend Detailer’s tools and materials, without overloading the palette drawers.

The methods for working with all libraries are the same. You can create new libraries, add tools or materials,
and move items between libraries.

It’s a good idea to limit the number of tools or materials in a library. This makes it easier to find a particular
tool and helps Detailer manage memory.

Brushes are loaded into memory when you launch Detailer, so adding brushes to the default brush library
increases Detailer’s need for RAM. If you are working close to the memory threshold, you’ll want to organize
new brushes into secondary libraries. When you want a different brush set, switch libraries. This will help
Detailer be more efficient with memory.




Adding tools or materials to the Current Library

As you work with Detailer and create new tools or materials, you can save them to the current library. The
command for adding an item depends on its type. In some cases, you click a Save button. In others, you
choose a menu command. And in the case of floaters, you drag them from the image into the library palette.

The method of adding a particular resource to the library is described in the section on customizing that
resource.



Loading Alternate Libraries
When you want to use the items in a different library, you can load that library.

When you save tools or materials, Detailer puts them in the current library. If this is not where you want
them, you must switch libraries before saving.

To switch libraries:
1 Open the palette drawer for the tools or materials you want to work with, for example, Brushes.
2 Click Library. Detailer displays a directory window.

3 Select a library, then click Open or OK. Detailer loads the items from that library into the palette.



Customizing Libraries

The controls for creating libraries and managing their contents are contained in the Movers. A Mover is

provided for each category supported by libraries—textures, patterns, gradations, brushes, nozzles, floaters
and 2D lights.



Accessing the Movers

Each kind of mover is accessed from a
different location.

Texture

To open the Texture Mover, choose
Materials palette: Texture menu> Texture Mover.

Pattern

To open the Pattern Mover, choose
Materials palette: Pattern menu> Pattern Mover.

Lighting (applied lighting, 2D effect)

To open the Lighting Mover, choose
Command-Shift-L (Macintosh) or Ctrl+Shift+L (Windows).

Floater

To open the Floater Mover, choose
Materials palette: Object menu> Floater Mover.

Brush Mover

To open the Brush Mover, choose
Brushes palette: Brushes menu> Brush Mover.

Nozzle

To open the Nozzle Mover, choose Brushes palette: Nozzle menu>
Nozzle Mover.

Gradations

To open the Gradation Mover, choose Materials palette: Color menu>
Grad Mover.

The features of working with Movers are described below. When you have finished working in the mover,
click Quit.



Creating a New Library

Create a new library first, then copy or save items to the library.

To create a new library:
1 Open the Mover for the library you want.
2 Click New. Detailer prompts you to name the new Library.

3Enter a descriptive name and click Save or OK.

It’s a good idea to save libraries in the same directory. This makes them easy to locate and load when you
want them.

The new library’s name appears on the right-hand side of the Mover window. The area above the name is
blank because this new library is empty. To put things in it, you can move them from other libraries.



Moving Items between Libraries
Movers copy items from the library open on one side of the dialog to the library open on the other side.

When you open a Mover, the resources of the current library are listed on the left. Often, this is the library
you’ll want to move from. If not, you can open a different library as the source. Click Close to close this
library. Then click Open and select a different library file.

The destination library must be open on the other side. If you just created a new library, it will be open. If
not, you may open an existing library. Click Open and select a library file.

When the source library is open on one side and the destination library is open on the other, you are ready to
move resources.

To copy an item between libraries:
1 Make sure the source library is on the left of the mover and the destination library is on the right.

2 Select the item you want to move. The Preview shows an icon of that item. In the case of brushes, the
Preview shows the icon associated with each brush.

3 Click Copy. Detailer copies that item to the other library.



Modifying a Library

If you want to delete a resource from a library, you may—but be careful. If you remove one of Detailer’s
default brushes by mistake, the only way to retrieve it is to reinstall Detailer. When you reinstall Detailer,
you’ll lose any of the custom resources you’ve created, unless you save them into other libraries.

See also:
Deleting ltems
Renaming Iltems
Changing Brush Icons
Deleting a Library



Deleting Items

To delete an item from a library:
1 From within the mover, Select the item you want to delete.

2 Click Remove.



Renaming Iltems

To change the name of an item:

1 select an item.
2 Click Change Name. Detailer displays a dialog.

3 Enter the new name and click OK. When Detailer asks if you’re sure you want to change the name, click
Yes.



Changing Brush Icons
Working with brushes, you have the additional option of replacing the icon used on the Brushes palette.

Before you open the Brush Mover, use the Rectangular Selection tool to select part of a 2D image you want
as the brush icon.

10pen the Brush Mover by choosing Brushes palette: Brushes menu> Brush Mover.
2 Select the brush whose picture you want to change.
3 Click Change Picture. Detailer displays the change that you are proposing.

4\f you’re sure you want to change the picture, click OK.



Deleting a Library

To delete an entire library on a Macintosh, go to the finder and drag the library to the trash. On Windows, you
may delete the file from the Windows~ 95 Explorer. You may also drag the file to the Recycle Bin.

Be careful not to delete one of Detailer’s default libraries. If Detailer can’t find the libraries it needs, you will
have to reinstall Detailer.




Default Libraries

When you launch Detailer, the program loads the default libraries. If you would prefer to load other libraries
on launch, you can change the defaults.

Default libraries must be located in the directory with the Detailer application program.

To specify default libraries choose Edit menu> Preferences> General.

In the Libraries portion of the General Preferences dialog, enter the exact file names for the libraries you
want Detailer to load as default.



About Plug-Ins

Detailer supports third-party Photoshop-compatible plug-ins such as Kai’s Power Tools. There are three kinds
of plug-ins: Filter plug-ins, Import plug-ins and Export plug-ins. Plug-in modules are available from Detailer
menus. However, the actual operation of these plug-ins is determined by the plug-in developer. You should
refer to the documentation that came with your plug-in modules for instructions on how they work.

If you are interested in developing plug-in modules, please contact Adobe Systems for Developer kit
information.

See also:
Filter Plug-ins
Import Plug-ins
Export Plug-ins

Making Plug-Ins Available to Detailer




Filter Plug-ins

Filter plug-ins appear after Detailer’s built-in effects, in the Effects menu. These Filter plug-ins are usually
comprised of special image-editing effects. Plug-in filters operate the same way that Detailer’s Effects
operate. If you have an active selection, the filter is applied to the selection. If you have no selection, the
filter is applied to the entire image. Once the effect is applied to a map image, that has been associated with
a model, the view updates in the Model Window.

Since, Detailer and Photoshop were developed by different companies, there may be filters that will run in
one program, but not another. Fractal Design has made a conscientious effort to maintain compatibility with
as many third party filters as possible. Check with the filter developer to find out whether there are any
compatibility problems between their product and Detailer. Please note that since Detailer is an RGB-based
program, it cannot run filters that are specific to CMYK or Grayscale modes.



Import Plug-ins
Import plug-ins are accessed through the File> Import submenu. The Import interface is generally used to

support file
formats that are not built-into Detailer.



Export Plug-ins
Export modules are used to export models. Export modules are available through the File> Export submenu.

Check our web site at www.fractal.com for new information and availability of import and export
plug-ins for different 3D file formats.




Making Plug-Ins Available to Detailer

When Detailer launches, it searches for plug-ins in two locations. Detailer first looks in the Detailer
application folder and in directories below it. The second place that Detailer looks is the folder specified by
the “Other Raster Plug-Ins” preference.

Before Detailer can display your plug-ins in the Effects menu, you must indicate where your plug-ins are
located on your hard drive. Detailer will load plug-ins from the selected directory and its sub-directories.

To locate the plug-ins folder in
Windows95:

Choose Edit menu> Preferences> Other Raster Plug-ins. Browse to select the directory containing your plug-
ins. Click OK. Restart Detailer to have this change take effect.

To locate the plug-ins folder in Macintosh:

1 Choose Edit menu> Preferences> Other Raster Plug-Ins. You will see an Open File dialog box. Use the
dialog to specify the directory that contains your plug-ins.

2 Click the Select Plug-ins button.

3 You will have to quit Detailer and then restart the program to load these plug-ins.

When Detailer starts-up it quickly displays the names of all available plug-ins on the start-up screen.

To use third-party 2D plug-ins from within Detailer:

Choose the Effects menu. You see a list of available plug-ins at the bottom of the menu. You can use them to
edit your image.

Plug-ins that are designed for grayscale or CMYK images may not work properly in Detailer.




Setting up Ray Dream Designer to Export Detailer Models

Detailer lets you work with models you’ve created in Ray Dream Designer. To do this, you’ll export from Ray
Dream Designer 4.1.2 or later in the Detailer file format. You can then open the exported file in Detailer.

Ray Dream Designer may be used independently or as a component of Ray Dream Studio. The export setup
and method is the same in both products.

Exporting from Ray Dream Designer is handled as an extension.
1 You must have Ray Dream Designer 4.1.2, or later, installed.
2 Look in the Detailer folder on your hard disk. Locate the folder “For Ray Dream Designer.” Open this folder.

3 Copy the two files in this folder to the Ray Dream Extensions folder.

The next time you launch Ray Dream Designer, the File> Export dialog will offer Detailer as a file type option.
You have several options for the export. See Fractal Design Detailer User Guide: Appendix B, “Using Detailer
with Other Programs,” for more information.



Setting Detailer's Preferences

Detailer has several preference dialogs: General, Brush Tracking, Interface, Other Raster Plug-ins, Undo,
Model and Windows.

See also:
General Preferences

Model Preferences




General Preferences
To display the general Detailer preferences dialog box, choose Edit menu> Preferences> General.
See also:

Cursor Setup

Setting the Default Libraries

Choosing aDefault Scratch Disk

Floater Pre-Feather

Draw Zoomed-out Views Using Area-averaging

Display Warning When Drawing Outside Selection



Cursor Setup

Detailer gives you several choices for the appearance of your cursor. To choose whether the cursor will be a
triangle or a single pixel, check the radio button next to Cursor Type. To determine the direction the cursor will
point (depending on your design and whether you’re left- or right-handed), click the appropriate button in the
circle above Orientation. To select a cursor color that will contrast with your working area and will therefore be
clearly visible, click the appropriate rectangle above Color.



Setting the Default Libraries

Detailer provides several libraries that contain many different brushes, textures, floaters, lights and color
sets, and you can create your own. By typing a file name in the text box next to Brushes, Textures, Floaters, and
Color Set, you can designate which libraries will appear in drawers when you open Detailer.



Choosing aDefault Scratch Disk

To select the disk volume that Detailer will write its temporary file on, choose the volume name from the
Temp File Volume pop-up menu.



Floater Pre-Feather

The Floater pre-feather box determines how much you can feather a floater. The default setting is 16 pixels,
making this the maximum setting allowed for theFeather slider in the Controls palette: Floater Adjuster tool.
You can change this default to any number up to 50. The change takes effect immediately.



Draw Zoomed-out Views Using Area-averaging

When looking at an image at less than 100% view, screen re-draw is faster if you leave this option disabled.
Drawing is slower but more accurate if this option is enabled.



Display Warning When Drawing Outside Selection

Enabling this option activates the warning that appears when you draw outside a selection. The warning will
not appear if this option is disabled.



Model Preferences
Choose Edit menu> Preferences> Model. Detailer displays the Model Preferences dialog.

See also:

Model Display During Movement
Wire Frame

Wire Frame with Depth Cueing
Anti-aliased Wire Frame

Anti-aliased Wire Frame with Depth Cueing

Fully Textured Rendering

Shaded Non-Textured Rendering
New Model Rounding Factor
Background Color

Mesh Color

Ray Dream Compatible



Model Display During Movement

Detailer lets you set an option for the model display during tracking. The model display option is only visible
when changing the view of a model.

To change the model display during movement, choose the setting you want from the pop-up menu.



Wire Frame

The model appears as a framework of wires.



Wire Frame with Depth Cueing

The model appears as a framework of wires. Wires that are distant appear fainter than those that are close.



Anti-aliased Wire Frame

The model appears as a framework of anti-aliased wires.



Anti-aliased Wire Frame with Depth Cueing

The model appears as a framework of anti-aliased wires. Wires that are distant appear fainter than those that
are close.



Fully Textured Rendering

The model appears rendered with all surface maps. This is a computation-intensive display mode. Updating
and tracking will be slower. Some systems might not be fast enough to work comfortably in this mode.



Shaded Non-Textured Rendering

The model appears with solid surfaces, but no surface maps.



New Model Rounding Factor

The rounding factor lets you add a degree of convexity or concavity to flat faces of the Detailer primitives
you create.

The valid range for rounding is -1 to 1. When the rounding factor is zero, models have perfectly flat faces.
Negative values make the flat faces appear slightly concave.

Positive values make the faces appear convex.



Background Color

The color of the Model Window Background is displayed on screen and in the final rendering. Sometimes a
light-colored object is easier to view on a dark background and vice-versa.

To change the window background color:
1 click the Background Color swatch. Detailer opens the system color picker

2 Choose a color for the window background. Model renderings will use this background color.



Mesh Color

The mesh is an optional overlay of mapping vertices on image files. The mesh makes it easier to paint on
map image files. Its color should contrast the colors in the map image, so the mesh is easier to see.

To change the mesh color:
1 Click the Mesh Color swatch. Detailer opens the system color picker.

2 Choose a color for the mesh.



Ray Dream Compatible

Detailer allows you to use a different mapping mode for each map type; however, this is rarely practical.
Usually, you’ll want all maps applied to an object to use the same mapping mode. This is a requirement for
detailed models you intend to export to Ray Dream Designer.

If you want all maps to use the same mapping mode, enable the Ray Dream Designer Compatible option.

When Ray Dream Compatible is enabled, you’ll set mapping options for the first map you apply to a model.
Detailer will automatically assign this mapping mode to all subsequent maps.

If you then change the mapping mode for one map, Detailer will update all maps to the new mode.

If you intend to export your Detailer model to Ray Dream Designer or Studio, enable the Ray Dream
Compatible preference before applying the second and successive maps. When exporting a model avoid
saving your image map files in RIFF format. We recommend you save your files in TIFF format.




Setting Pressure Sensitivity

When you draw with Natural-Media, the amount of pressure you use with a tool determines how dense and
how wide your strokes are. Using a pressure-sensitive stylus with Detailer gives you this same kind of
flexibility. Each artist bears down on a drawing or painting tool differently. In Detailer, you can program the
computer to react to your individual touch just by dragging in the Brush Tracking dialog box.

To display the Brush Tracking dialog box, choose Edit menu> Preferences> Brush Tracking.

To set how sensitive the stylus will be to your hand pressure and speed, move the stylus across the scratch
pad area at a normal speed and with a normal amount of pressure.

Just as your signature varies, so will the way you work with the stylus at any given time, so you’ll set
upBrush Tracking each time you start Detailer. When you exit Detailer, the Brush Tracking sliders go back to
their default settings.



Customizing the Interface

Fractal Design has chosen colors and textures for Detailer’s interface that we think are aesthetically pleasing
and very legible. However, you may want to experiment with your own interface colors and textures.

To change Detailer’s interface, choose Edit menu> Preferences> Interface. The Interface Preferences dialog
box appears.

To change the icon selection color:
1 Using the Materials: Color palette or the Dropper tool, choose the color you wish to use.

2 Click the Use Current Color button under Icon Selection Color. The selection box changes to the currently
selected color. This color is used until you change it again.

To change the shadows under palette icons:

1 Enter new values in the boxes under Rectangular Shadows.

The X-Offset moves the shadow horizontally, and the Y-Offset moves the shadow vertically. Softness refers to
the amount of feathering the shadow has.

2 After entering the values, click Done. Watch an icon as its shadow changes. Repeat the procedure with
different values if you aren’t happy with the changes.

To change the rectangular pillowing:

1 Enter new values in the boxes under Rectangular Pillowing.

Rectangular pillowing refers to the shadows beneath sliders and rectangular items in palettes other than
icons. The X-Offset moves the shadow horizontally, and the Y-Offset moves the shadow vertically. Softness
refers to the amount offeathering the shadowing has.

2 After entering the values, click Done. Watch the palette shadows change. Repeat the procedure with
different values if you aren’t happy with the changes.

To change the palette background texture:

1 Choose the texture you wish to use in the Texture palette.

2 Choose Edit menu> Preferences> Interface. In the Interface Preferences dialog box, under Palette
Background Texture, click in grayscale if you wish the texture to be rendered in grayscale; click in current
colors if you wish the texture to be rendered in the current primary and secondary colors.

3 Click the Use Current Texture button.

4 Click Done. Your palette background texture changes.

To use the current pattern as the palette background texture:

1 Choose one of the default patterns or use the Rectangular Selection tool to select part of an image to
capture as a pattern. Choose Materials palette: Patterns menu> Capture Pattern.

2 Return to the preferences dialog and click the Use Current Pattern button. The palettes will update so you can
preview your choice.

3 Click Done. Your palette background texture changes to the current pattern.

To change the drawer bottom texture, follow the steps above, but use the buttons under Drawer Bottom
Texture.

To change the window background color:
1 set the current color using the Materials: Colors palette or Dropper tool.

2 Click the Use Current Color button under Window Background Color. The background is filled with the
current color.

When in current colors is selected in the Interface Preferences, Detailer uses the primary and secondary
colors from the Materials: Color palette to customize interface elements. Experiment with two colors for




interesting effects.

You may save your interface preferences by clicking the Save button in the bottom right of the Interface
Preferences dialog box. A standard save dialog appears asking you to name the interface setting. Give it a
descriptive name and click Save.

To load a saved interface set:
1 click the Load button.
2 Choose the interface set from the directory box that appears.

3 Click Open to load the interface set.

To return to Detailer’s default interface:
1 Click the Use Defaults button at the bottom of the palette.

2 Click Done. Detailer reverts to the default interface.



Setting Multiple Undo Levels

Multiple Undo allows you to undo and redo up to 32 levels of changes. The number of undo levels is set in
Undo Preferences, found under Edit menu> Preferences> Undo. Five levels are set as a default.

Undo levels apply across open documents. With five levels set, if you have two documents open and you
have “undone” three operations on the first document, you can only undo two operations on the second.

Multiple Undo can use a significant amount of disk space. If you perform multiple operations on the entire
image, the whole image must be saved for each undo step. So be careful with the number of Undo levels you
choose to save.



Preferences for Windows
Choose Edit menu> Preferences> Windows to display memory and printing options.
See also:

Physical Memory Usage

Printing Options

Display Option



Physical Memory Usage

For best performance, choose Maximum Memory for Detailer and run Detailer with no other programs
running in the background. Choosing Half Memory for Detailer will allow Detailer to run more efficiently with
other Windows applications running at the same time.



Printing Options

Free Memory for Printing will increase printing speed by writing the active image to disk, increasing the
amount of memory available for the print manager and the printer driver.

No Print Banding disables print banding for devices that support it. Disabling print banding may help some
PostScript printers, but will hurt the performance of some bitmap printers, such as the Hewlett-Packard
DeskJet printers. Most dot matrix printers will be faster with No Print Banding left unchecked in the dialog
box. If you experience problems printing in landscape orientation, you may have to turn off banding by
checking the radio button in the dialog box.



Display Option

If your video display driver is set to 32,000 colors, you may experience some color irregularities on your
screen when using Detailer. Checking No Device Dependent Bitmaps will correct this problem with most
32,000-color video displays. If you are not using 32,000 colors, this checkbox will have no effect on your
system.



Detailer Basics

See also:
How Detailer Works

Working in the Model Window
Objects and Maps

Rendering an Image
Saving and Quittin




How Detailer Works

Detailer takes two-dimensional images and wraps them onto the model in a process called mapping. The
images develop the surface of the model. Depending on the images and settings you use, the model can
become wood, metal, stone, plastic, even skin.

When you work in Detailer, you’ll open a model, select an object, and apply images as surface maps. You’ll
set lights, and ultimately create a rendering of the finished model. You may export your finished model for
use in another 3D program.

See also:
Models

Objects
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Map Image Files
Mapping Methods
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Rendering



Models

You have several options for generating and importing models, including creating primitives in Detailer and
opening 3D files created in Fractal Design Ray Dream Designer.

When you open a model, Detailer displays the 3D View of it in the Model Window. You can rotate your view of
the model, zoom in, and move the model in the window.



Objects

Models may be comprised of up to 240 separate objects. Each object may have completely different colors
and surface characteristics.

When your model has several objects in it, you’ll select the object you want to detail.

If you want to apply maps to more than one object simultaneously, you will have to combine the objects into
one with a modeling application like Fractal Design Ray Dream Designer.




Maps

When you’ve selected an object, you’ll apply one or more two-dimensional images to its surface. Detailer
maps these 2D images onto the 3D object to give it color, surface relief, and control the interaction with
light.

For each object in the model, you may load one image for each of five map types, or leave any channel
empty. The five map types are as follows:

Texture Map

The Texture Map adds color.

Bump Map

The Bump Map creates surface relief (physical texture).
Highlight Mask

The Highlight Mask controls the highlight in different areas. Dark areas of the mask reduce the highlight.
Using black and white, and shades of gray, you can specify which areas on a surface are shiny or matte.

Reflection Mask
The Reflection Mask controls the reflection in different areas. Dark areas of the mask reduce the reflection.
Glow Map

The Glow Map applies additional color after the other maps have been applied. The glow map is useful for
describing objects that emit light such as lamps or LEDs.



Map Image Files

When you apply a map, Detailer opens the map image in a window. You can see the 2D map image file and
work in this window. When you save the model, you’ll save all of these image files along with it.

The effect of the maps you apply appear immediately on the surface of the object in the Model Window. That
is, when you apply a texture map, the imagery in the map appears immediately on the 3D object. Any
changes you make in the map image file, like painting brush strokes, appear immediately on the object.

You may develop imagery working in the 2D image window, or you may paint directly on the object. In either
case, only one map image file is active for editing at a time. You must specify which map you want to “paint
into” to make changes. You do this on the Materials: Object palette or by activating the image’s window.



Mapping Methods

Detailer offers several methods for mapping the 2D image onto the 3D object. Each method is suited for
objects of different shape. The mapping mode you choose, and how you design the imagery, makes a huge
difference in how the map appears on the object.



Lighting

Several of the surface effects depend on light. Detailer’s Light tool and the Materials: Light palette makes it
easy to shine lights on your model. You can color or dim the lights to light the object just how you want it.



Rendering

When you’re satisfied with the maps you’ve applied, the light and other settings, you can render the image
at higher resolution. The rendering can be a larger, anti-aliased version of what you see in the Model Window.
The rendering includes a mask of the model, so compositing with other images is clean and easy. You can
composite images directly in Detailer or in a 2D application like Fractal Design Painter.



Working in the Model Window

The Model Window shows a 3D view of the model you are working on. When you’re adding detail to a model,
you’ll want to keep the area you’re painting centered in the window, at a reasonable scale, and square to
your view.

Detailer provides three navigation tools that make it easy to view and paint on any surface of the model—the
Virtual Trackball, the Magnifier and the Grabber.

Key shortcuts let you temporarily switch to the navigation tools.
To switch to Virtual Trackball, choose Option-Spacebar for Macintosh, Spacebar+Alt for Windows.

To zoom-in: Command-Spacebar for Macintosh, Spacebar+Ctrl for Windows.

To zoom-out: Command-Option-Spacebar for Macintosh, Spacebar+Ctrl+Alt for Windows.

To switch to the Grabber, hold down the Spacebar.

Note: The Macintosh System has a keyboard option for cycling through different keyboard layouts. You’ll want
to make sure this is disabled before zooming out—otherwise your keyboard might start acting funny. Choose
Apple menu> Control Panels> Keyboard. In the dialog, make sure the Command-Option-Spacebar feature is

disabled.

See also:

Using the  Virtual Trackball

Rotation on Axis

Controlled Rotation

Magnifying your Subject

Magnification Pop-up Menu

Using the Grabber tool to Pan the Model Window
Changing the Size of the Model Window

Setting the Model Window Background Color
Importing a  Background Image

Clearing and Showing the Background Image




Using the Virtual Trackball

You can view the model from any angle by rotating your view. Viewing from a particular angle helps when
you’re painting. It’s much easier to work when you’re facing the surface you’re painting. Trying to paint
oblique surfaces (on the side or edge of an object) can be difficult.

To change the 3D view:
1 choose the Virtual Trackball tool.

2 In the Model Window, drag to rotate your view of the model.

In the model space, the model doesn’t move. The model is fixed with respect to the lights. When you use the
Virtual Trackball, you’re changing your view of the model. That is, the model stays in one place and you
move around it. You may want to adjust lighting after rotating your view.

With the model starting in this position, the following diagrams show the path you would drag to rotate the
view as shown.



Rotation on Axis
Rotation on the X Axis
Drag down from the center of the window to view from above.
Rotation on the Y Axis
Drag left or right from the center of the window to view from the other side.
Rotation on the Z Axis
Drag in a circle from a corner of the window to change which side is up.
Rotation on Several Axes
Drag at an angle to compound rotation.

If you move around the model, you might find an area that is dark. This is because there is no light shining
from that side. You could add a light to shine there, you could increase ambient light, or enable the Flat
Lighting option in the Materials: Light palette.

See also:

Using Light



Controlled Rotation

When the Virtual Trackball is selected, the Controls palette provides sliders for rotating the view on the X, Y
and Z axes. The x axis runs horizontally. The y axis runs vertically. The z axis runs perpendicular to the plane
of your monitor screen.

Drag the slider for the direction you want to rotate the view.

The direct view of the north pole, in the model space, is 0j, 0j, 0j. A direct view of the front would be 90j, 0j,
0j.



Magnifying your Subject

The Magnifier works in image windows and in the Model Window.

To zoom in:
1 Choose the Magnifier tool.

2 Click on the area you want to view closer. You can also drag a marquee around the area you want to
magnify. Detailer zooms to the highest level that will display the full area of the marquee.

To move back and get a larger view:
1 Hold down the Option key for Macintosh or Alt for Windows.

2 Click in the window.



Magnification Pop-up Menu

When in an image window, the Controls palette: Magnifier tool provides a pop-up with a set of
magnification factors. Select the level you want and Detailer immediately sets the magnification to that
level.



Using the Grabber tool to Pan the Model Window

Use the Grabber tool to center the area you’re working on in the window. The Grabber works in the Model
Window and in image windows.

To pan the Model Window:
1 choose the Grabber tool.

2 Drag the model (or image) to view the area you want.



Changing the Size of the Model Window

You can change the size of the Model Window at any time.

To change the size of the Model Window:

1 Choose Window menu> Set 3D View Size. Detailer displays a dialog that allows you to set the size of the
Model Window.

2 Enter width and height values (in pixels) for the size Model Window you want.

The dialog shows how much RAM is required for the window specified. A larger window may be more
comfortable to work in, but requires more RAM. The bigger the window, the longer it takes to display. A large
window might not be possible on your system.

3 Click OK, Detailer sets the Model Window to the new size.

Don’t set a Model Window that requires more RAM than your system has available. Between 200 and 300
pixels square is a good size for most systems.




Setting the Model Window Background Color

You can choose a color for the background of the Model Window. You might want to use a dark background
with a light colored image and vice-versa.

If you are creating a 2D collage of several renderings, you will want to set the background color accordingly.

To change the background color:

1 Choose Edit menu> Preferences> Model. Detailer displays the Model Preferences dialog.

The other model preferences are described at the end of Getting Acquainted with Detailer.

2 Click the swatch for Background Color. Detailer opens the system color picker so you can choose a color for
the window background.



Importing a Background Image

Detailer lets you import an image as the background of the Model Window. You can use the image in the
rendering of the finished model. This enables you to adjust the surface maps, lighting, and view of your
model to match the imagery in the scene.

When you render the 3D view, the background is included in the image.

To import a background:

1 open the model you are working on.

2 Choose File menu> Import> Background. Detailer displays a dialog that allows you to locate and open the
file you want to use.

The file may be in certain image formats that Detailer supports: RIFF, TIFF, PICT, Photoshop 2.0 and 3.0, BMP,
PCX, TARGA, and JPEG.

The background will appear in the Model Window, aligned at the top, left corner.

If the background image is larger than the Model Window, only the upper left region will be visible. If this
does not work out for you, create a new image that is either scaled or cropped to the region you want.

If the background image is smaller than the Model Window, the image will be repeated (tiled) to cover the
area.

The background image file cannot be edited while it is associated with the model. If you need to edit the
background image, you’ll need to import it again.

If you need to edit the background image, it can be opened in Detailer as a 2D image. You can apply paint
and effects, save it and close it. Then it may be imported as a background again.




Clearing and Showing the Background Image

You might want to temporarily remove the background image. Perhaps you find the image a distraction to
your painting or you want to render without it.

To clear the background image:
1 Bring the Model Window to the front.

2 Choose Window menu> Clear Background. Detailer sets the window to display the background color.

To show the background image:
1 Bring the Model Window to the front.

2 Choose Window menu> Show Background. Detailer sets the window to display the background image.



Objects and Maps

A Detailer model may be constructed of up to 240 separate objects. Each object may have a unique set of
maps applied to it. When you work with a multi-object model, you need to select which object you want to
detail.

To select an object:

1 choose the Object Selection tool.

2 In the Model Window, click on the object you want. The selected object appears outlined in the 3D view.

In @ model comprised of a single object, like Detailer’s own primitives, that object is automatically selected.




The Object Palette

All of the features for applying and controlling maps are found on the Map menu and on the Materials: Object
palette. The features appear in both places to give you a choice of how to work.

Using Maps describes all of the features for applying maps to objects.

The Object palette lists the five map types that may be applied to the object: Texture, Bump, Highlight,
Reflection, and Glow.

When you select an object, the Object palette updates to show the settings and maps (if maps are loaded for
this object).

In each map type listing, you will see two icons to the left of the map type, and the name of the map file to
the right. The “X X” beside a map type listing indicates that this object does not have a map of this type
loaded.

The Eye and Pencil icons indicate that this object does have a map of this type. The map file name appears
on the right of the listing.

The Eye icon controls whether this map is displayed on the object. When the Eye is open, the map is
rendered to the object in the Model Window. When the Eye is shut, this map is not applied. You can click the
Eye to open and close it.

The Pencil icon controls which map is active for editing. Only one map can be edited at a time. The Pencil
icon for the active map is clear—the other Pencil icons have a red slash over them.

Clicking once on the Pencil icon (next to the map type in the Objects palette) brings the map to the front so
you can paint in it.

This has the same function as choosing Map menu> Paint Into> and selecting the map you want to work on.




Rendering an Image

You can render the 3D view of your model to a separate image at any time. The rendering you create will be
a high resolution version of what you see in the Model Window. The rendering includes a mask, which makes
it easy to composite it with other images.

Detailer’s rendering camera does not create perspective views of the model. If you want a true perspective
effect, you can export your Detailer model to Fractal Design Ray Dream Designer or another 3D program.

See also:

Render to Image
Using Renderings in Detailer



Render to Image

Rendering settings are found in the Render to Image dialog.

To render the 3D view:

1 Before rendering, use the Virtual Trackball, Magnifier, and Grabber to set the view of the model. Set the
lights how you want them.

2 Choose File menu> Render to Image. Detailer displays a dialog that lets you set rendering options.

3 Enter width and height values (in pixels) for the rendering resolution you want.

The values you enter should conform to the aspect ratio of the Model Window. Values that describe a
different aspect can lead to unexpected results in the rendering.

4 set your anti-aliasing options.

If you intend to composite the model with other images, you want to use the Anti-alias Mask option and not
the Anti-alias Image option.

Anti-alias Image: when this option is enabled, pixels at the edge of the model are faded to the background
color. Anti-aliasing the image creates a softer edge.

Use this option if you intend to use the rendering as a complete image.
Anti-aliased images take significantly longer to render.

Anti-alias Mask: when this option is enabled, mask pixels at the edge of the model’s shape are given
intermediate density values.

Use this option (and disable Anti-alias Image) if you intend to composite the model with other images.

In Fractal Design Detailer, when you convert the masked area to a selection and float it, the image pixels at
the edge of the object will be semi-transparent. Their level of opacity is directly proportional to the density of
the corresponding mask pixels.

When you move this floater over other imagery, some portion of the background colors will be visible
through the semi-transparent pixels at the edge of the floater. This gives the floating image a nice, soft edge
for compositing.

If you will be using your rendering as a finished image, choose to anti-alias the image but not the mask. If
you are going to turn your rendering into a floater or layer, choose the anti-alias the mask, but not the
image.

5when you click OK, Detailer renders the image. Rendering can take some time, depending on the
resolution you requested and the speed of your system. When the rendering is ready, Detailer opens it in a
new image window.

If you like the results, save the image file. If the rendering isn’t what you expected, close the window without
saving changes. Adjust your model, maps, or lights and render again.

Not all formats maintain the mask information. Save in RIFF, TIFF or Photoshop formats to maintain the mask
information.

Look in Appendix B, “Using Detailer with Other Programs,” for tips on compositing your rendering with other
images in Fractal Design Painter.




Using Renderings in Detailer

Often youw’ll want to composite the image of the rendered model with other imagery. The mask Detailer
creates in the rendering makes compositing easy.

To composite your renderings in Detailer:

1 Open the saved rendering in Detailer.

The rendering must be saved in a format that retains the mask (RIFF, TIFF, or
Photoshop formats).

2 Set the Visibility mode to Show Selection. The selection marquee appears around the model shape.
3 Choose Edit menu> Copy.

4 You can now move to another file and paste the selection. The selection is pasted as a floater.
See also:

Floaters



Saving and Quitting

A model that you have detailed may have up to five maps for each object. If the model is comprised of a
number of objects, there may be quite a few image files used for this one model. You’ll need to save all these
image files with the model.

When you select the Save command, Detailer applies it to the foremost window.
When an image window is active, Detailer saves that image.

When the Model Window is in front, Detailer saves the model. If any map images have not been saved,
Detailer requires you to save them before saving the model file. When you save the model, Detailer prompts
you to save any unsaved maps associated with the model.

Map image windows must remain open while you are working with the model. If you close a map image
window, that map becomes dissociated from the model.




Working with Models
See also:
Obtaining Models
The Model in Detailer




Obtaining Models

Detailer lets you paint and develop surfaces on three-dimensional models. To do this, you’ll need to create a
model in Detailer. You may also open or import a saved model file.

A Detailer model is a file comprised of one or more 3D objects. The model may have up to 240 objects, and
each object may have a different set of surface maps and properties. For example, a wooden handle,
corkscrew, and the cork it’s stuck in are three separate objects, but may be grouped as a single model.

Detailer has an engine for creating primitive objects. Detailer also comes with a catalog of interesting models
you can work with. Some artists will import models they’ve created in a 3D modeling program, like Fractal
Design Ray Dream Designer.

See also:

Creating a Detailer Primitive

Opening Saved Models

Importing Models




Creating a Detailer Primitive

Detailer primitive models are single objects.

To create a primitive:

1 choose File menu> New Model. Detailer displays a dialog that lets you choose the model type.

2 Use the pop-up to choose the model you want: Box, Cylinder, Cone, Sphere, or Cup.

3 After choosing a primitive, click OK. Detailer prompts you to select options for the selected primitive

model.

Dimensions. Enter dimensions that describe the size of the model you want. The dimensions required depend
on the model type.

Tolerance: Detailer models are constructed of triangular faces. The Tolerance setting allows you to control the
number of triangles used to approximate curved surfaces in the model.

e The Coarse setting creates the fewest triangles. You may see irregularities in renderings.
® The Medium setting creates more triangles than the Coarse setting, but not as many as Fine.
* The Fine setting creates the most triangles, which assures a clean image.

More triangles increase memory demands and may slow down some operations. See Appendix C,
“Qptimizing Memory Usage,” for information about dealing with memory limitations.

4 pfter exploring the options, click OK to confirm the model settings. Detailer prompts you to choose a size
for the 3D View or Model Window.

5 Enter width and height values for the size Model Window you want. You can get closer to the model by
zooming in with the Magnifier tool, so a large window may not be necessary.

The dialog shows how much RAM is required for the window specified. The 3D view or Model Window requires
52 bytes per pixel. A larger window may be more comfortable to work in, but requires more RAM. Larger
model windows update slower on screen. A large window might not be possible on your system.

Don’t set a Model Window that requires more RAM than your system has available. See Appendix C,
“Optimizing Memory Usage,” for information on optimizing Detailer for the level of RAM in your system. See
your Detailer Quickstart Guide for information about setting the application memory.

6 Click OK to set the Model Window size. Detailer opens the model in the 3D View or Model Window.



Opening Saved Models

Models you save in Detailer will be in Detailer format. The catalog of models on the Detailer CD are all in
Detailer format. You can also export models you create in Ray Dream Designer in Detailer format.

To open a Detailer model:

1 choose File menu> Open. Detailer displays a dialog asking you to choose between Model and Image
files.

2 Choose Model and click OK. Detailer displays a dialog that asks you to locate and select a saved Detailer
model.

3if you are opening an Detailer model exported from Ray Dream Designer, for the first time, Detailer
prompts you to choose a size for the 3D View or Model Window. Enter width and height values for the size
Model Window you want.

Detailer will open all maps and images associated with this model. However, if a file has been moved or
renamed, Detailer won’t be able to load it. In this case, Detailer displays a dialog giving you a chance to
locate the missing file. If you cancel the dialog without selecting an image, Detailer opens the model without
a map, background, or reflection environment.

See also:

Opening Models Created in Ray Dream Designer



Opening Models Created in Ray Dream Designer

You can create your own models in Ray Dream Designer or Ray Dream Studio and open them in Detailer.
Before you can open them, you must export them from Ray Dream Designer or Studio in Detailer format. The
export feature is a program extension for Ray Dream Designer 4.1.2, or later.

This extension is a pair of files (“Detailer” and “DETAILER.DTA”) that are part of the Detailer installation in a
folder called “For Ray Dream Designer.” You’ll need to copy these files to the Ray Dream Designer Extensions
folder.

To export a model from Ray Dream Designer in Detailer format:

1in Ray Dream Designer 4.1.2, select the object or object group you want.

You may select the Universe group to export the entire scene (lights and
cameras are not exported).

A group may have no more than approximately 80 objects in it.

Because end caps on extruded geometries are individually treated as separate objects, a group may have no
more than approximately 80 objects in it. With two end caps each, that would amount to approximately 240
objects in Detailer. Some objects may have no end caps and others may have multiple caps on each end
(depending on the geometry), that’s why these numbers are approximations.

2 Choose File menu> Export. The program displays a dialog that lets you select the export type, file name,
and save location.

3 Choose Detailer from the Format pop-up. Enter a file name and select a folder on your disk.
Note: If “Detailer” does not appear in the list, you haven’t copied the export extensions to the correct folder.
See also:
Setting up Ray Dream Designer to Export Detailer Models
4t you want to change your export options, click Options.

The options give you control over several model characteristics, including the number of objects created.
Your mapping capabilities (and your ability to import the work you do in Detailer back into Designer) may
depend on your export option choices. You’ll find complete descriptions of the Export Options in Appendix B,
“Using Detailer with Other Programs.”

5 After closing the Options dialog, click OK. The program creates the Detailer model file.

You can now open the model in Detailer.



Importing Models

Detailer lets you import models saved in 3DMF (Macintosh version only) and 3D Studio (Windows version
only).

To import a model:
1 choose File menu> Import and select the format of the file you want to import.

2 Use the import dialog to locate and select the file. Click OK.

Once imported, the model appears as any Detailer model. When you save the model in Detailer, you will be
saving it in the Detailer format. If you want to move the file back to your 3D modeling and rendering
program, you’ll need to export it from Detailer.



The Model in Detailer
See also:Selecting an Object within aMulti-object Model
Getting Technical Information
Setting Object Base Color
Setting Object Properties
Saving a Detailer Model

Closing a _Model
Exporting Models




Selecting an Object within aMulti-object Model

A Detailer model may be constructed of up to approximately 240 separate objects. Each object may have a
unique set of maps applied to it.

When you work with a multi-object model, you need to select which object you want to work on.

When a model is comprised of a single object, like Detailer’s own primitives, that object is automatically
selected.

If you try and paint on an object that isn’t selected, Detailer will ask you if you want to select it. If you click
Yes, and you have already applied maps to the object, Detailer will ask you if you want to paint in the first
map it finds. If you click Yes and you do not have any maps applied to the object, Detailer will ask you if you
would like to create a Blank map or one based on a pattern or texture.

To select an object:

1 Choose the Object Selection tool.

2 In the Model Window, click on the object you want. The selected object appears outlined in the Model
Window.

When you select an object, the Materials: Objects palette updates to show the settings and maps, if any are
loaded for this object.

The Controls palette: Object Selection tool displays technical information describing the selected object.

The minX, minY, and minZ and maxX, maxY, and maxZ describe the dimensions of the bounding box of this
object. The bounding box is the smallest box that will enclose the object completely.

The Controls palette also gives the number of triangles in the surface mesh.

See also:



Getting Technical Information

You can get technical information for points on the object.

To obtain 3D information:

1 Choose the Object Selection tool.

2 Hold down the Control key (Macintosh), Shift+Ctrl keys (Windows), and click on a point of interest on the
model.

Detailer displays an Object Report, describing that point on the model, its normal vector, and correlation to
the texture map. Some 3D artists might find this information useful.



Setting Object Base Color
You may color an object without applying a texture map.

Setting a base color doesn’t make sense if you intend to apply a texture map. The texture map hides the
base color completely. However, if you want the object to have a single, flat color, you can set its base color.
This is useful when you have a multi-object model and you only want to create texture maps for a few
objects.

To give the model a base color:

1 select the object you want to color.

2 Display the Materials palette.

3 Choose Materials palette: Object menu> Set Object Color.

Detailer displays the system color picker. Select a color for the object and click OK.

To set the base color of an object using the Dropper tool:
1 Use the Materials: Color palette to choose a color.
2 Select the Dropper tool.

3 Hold down the Option key (Macintosh), Alt key (Windows), and click the object you want to color.

To give all objects in a multi-object model the same color:
1 choose Materials palette: Object menu> Set All Objects Colors. Detailer displays the system color picker.

2 Select a color and click OK. Detailer will apply the color you select to all objects in the model.



Setting Object Properties

The Object palette provides controls for an object’s basic shading properties. These properties control how
the object appears under the lights. Particular settings help describe the object’s substance—whether it is
glass, metal, cork, skin, or whatever.

Select the object whose properties you want to adjust. Drag the Diffuse, Specular, and Reflection sliders to
set levels appropriate to your object’s surface.

See also:
Diffuse

Specular
Reflection



Diffuse

The Diffuse slider controls how much base color the object shows.



Specular

The Specular slider controls the object’s tendency to show highlights. Highlights are the bright spots and
streaks that appear on an object where light is reflected directly.

You can control specularity in regions of the object with the highlight mask.



Reflection

The Reflection slider controls the object’s tendency to reflect its environment. Moving the Reflection slider
to the right allows more of the environment image to appear reflected in the object.

You can control reflection in regions of the object with the reflection mask.

Reflection is useful when a good reflection map is loaded as the environment. If you do not have an image,
Detailer will use the current pattern.

See also:Using an Environment Map for Reflection

The settings below offer recipes for achieving different surfaces:
Material  Diffuse  Specular Reflection

Chalk 100% 0% 0%

Obsidian 0% 100% 0%

Mirror 100% 100% 100%

Plastic 60% 40% 0%




Saving a Detailer Model

After developing the surface of your model, save your work. You’ll be able to open the model later and
continue working. Saved models include settings for object properties, lights, and all references to applied
maps, the background, and environment.

A finished Detailer model consists of several files—the 3D model itself and each image file used as a map,
environment, or background. For the sake of organization, it’s a good idea to keep your model with its image
files in a new directory/folder.

To save a Detailer model:

1 Bring the Model Window to the front. You can click in the window or select its listing from the Window
menu. Model Windows appear at the bottom of the menu.

2 Choose File menu> Save.

If your model has maps associated with it that have not been saved, Detailer requires you to save them now.
Detailer will display a Save Image dialog for each image that has not already been saved.

Stay organized! Create a directory/folder named appropriately for this model and save all images associated
with the model to this folder.

3 save the map files to the same location. Name each file accordingly.

If you use floaters in your image and want to preserve them as independent floating objects, you must save
in either the RIFF or Photoshop 3 file formats. To keep file size to a minimum, use the RIFF file format. If you
intend to export your model, use the TIFF file format.

4 when all images have been saved, Detailer opens a Save dialog for the model. In the Save dialog, enter a
name for your model and click OK.



Closinga Model

The windows of the map images must remain open to stay connected with the model. This means you should
close the Model Window first. Then Detailer can close the image files.

To close a Detailer model:

1 Bring the Model Window to the front.

2 Click the window’s close box, or choose File menu> Close. If you haven’t saved the model, Detailer will

alert you and give you a chance to do so. Detailer will close each map file as well, alerting you to save if
necessary.



Exporting Models

Detailer is a powerful tool for developing surfaces on 3D models. Detailer lets you render a model, but many
artists will want to move their finished models to a full featured 3D program, like Fractal Design Ray Dream
Designer, for assembling in a 3D scene and rendering.

Ray Dream Designer/Studio offers features that Detailer doesn’t, including:
® You can create a scene with numerous models.

* You can develop sophisticated lighting and rendering effects, like shadows, luminous objects, and
translucence.

* You can achieve different perspective effects with an adjustable camera.
® You can create animations in Studio.

These are only a few of the benefits you get from moving your Detailer models to a scene-building and
rendering program like Ray Dream Designer or Studio.

Ray Dream Designer and Studio can import models saved in Detailer format. The model retains its surface
properties and all of the maps applied to it. When you import the model in Ray Dream Designer, all of your
details, including the alignment of the maps, will be intact.

For models created in Ray Dream Designer, you have the option of importing just the maps and shading from
Detailer. Designer automatically applies the maps to the existing model objects.

See Appendix B, “Using Detailer with Other Programs,” for more information on importing Detailer models in
Designer. Additional information may be in the ReadMe file in the Detailer folder and at our web site,
www.fractal.com.

Several aspects of the Detailer model might not apply when you move to a separate 3D program. The
background image, reflection environment, and the lights are discarded. You’ll want to develop these aspects
of the scene in your 3D scene-building program.

Detailer can export models in several formats.
® QuickDraw 3D, also known as 3DMF (Macintosh only)
* 3D Studio (Windows only)

To export a Detailer model:

1 Open the model you want to export.

2 Choose File menu> Export and select the format you want to use.

3The program displays a dialog that lets you name the file and choose a save location.

4 Click OK. The program creates the exported model file.
You can now import the mod